16 Ene 2009 @ 12:15 PM 

1. Escriba un algoritmo que pida el ingreso por teclado de dos números enteros  y que muestre por pantalla la suma, resta, producto y división de los mismos.

Solución

inicio

//Declarando variables a usar

	var entero A
	var entero B
	var entero suma
	var entero resta
	var entero producto
	var entero division
	escribir("Ingrese un numero: ") //Solicitando ingreso de datos por teclado
	leer(A) //Leyendo el primer número desde el teclado
	escribir("Ingrese un numero: ") //Solicitando ingreso de datos por teclado
	leer(B) // Leyendo el segundo número desde el teclado
	// Realizando operaciones
	suma = A +B
	resta = A - B
	producto = A*B
	division = A/B
	//mostrando resultados
	escribir("La suma es: ")
	escribir(suma)
	escribir("La resta es: ")
	escribir(resta)
	escribir("El producto es:")
	escribir(producto)
	escribir("La division  es: ")
	escribir(division)
fin

2. Escriba un algoritmo que muestre por pantalla un menú y que solicite el ingreso por teclado de una opción del mismo; cuando se haya elegido dicha opción le indique al usuario su elección.

Solución:

inicio
	//Declarando las variables
	var entero opcion
	//Mostrando el menú
	escribir("1.  Opción 1")
	escribir("2.  Opción 2")
	escribir("3.  Opción 3")
	escribir("4.  Salir")
	escribir("Ingrese una opción: ") //Solicitando el ingreso de datos por teclado
	leer(opcion) //Leyendo la opción ingresada por teclado
	segun_sea (opcion)
		caso 1: //opción 1
			escribir("Usted ha elegido la opción 1")
			interrumpir
		caso 2: //opción 2
			escribir("Usted ha elegido la opción 2")
			interrumpir
		caso 3: //opción 3
			escribir("Usted ha elegido la opción 3")
			interrumpir
		caso 4: //opción 4
			escribir("Usted ha elegido la opción Salir")
			interrumpir
		otros: //Si no coincide con los casos anteriores
			escribir("Opcion no válida")
			interrumpir
	fin_segun
fin

En este algoritmo se utilizó una  estructura de selección que nos permite relacionar un conjunto de acciones al valor de la variable dada como parámetro, este menú está constituido de 4 opciones (opción 1, opción 2, opción 3 y salir), las cuales están definidas en cada caso; además cuando se ingresa un valor que nocoincide con los casos definidos, se realizan las acciones descritas en «otros«.

3. Escriba un algoritmo que repita una cadena de caracteres un número de veces dado.

Solución:

Existen muchas formas de realizar esto:

inicio
	//declarando variables
	var cadena cadena1
	var entero veces
	var entero contador
	escribir("Ingrese una cadena de caracteres")
	leer(cadena1)
	escribir("Ingrese el número de veces que desea que se repita la cadena")
	leer(veces)
	contador = 0 //Inicializando el contador
	mientras(contador < veces ) //Repitiendo mientras el contador sea menor que el número 
		escribir(cadena1)   //de veces
		contador++//incrementando el contador
	fin_mientras
fin

Otra forma

inicio
//declarando variables
	var cadena cadena1
	var entero veces
	var entero contador
	escribir("Ingrese una cadena de caracteres")
	leer(cadena1)
	escribir("Ingrese el número de veces que desea que se repita la cadena")
	leer(veces)
	/*La estructura "para" asigna el un valor al contador, evalúa una condición y si esta se
	cumple, se realizan las acciones indicadas, luego se incrementa el contador */
	para contador=0 hasta contador<veces contador++
		escribir(cadena1)
	fin_para
fin
Posted By: lgavidia
Last Edit: 21 Ene 2009 @ 10:14 PM

EmailPermalinkComments (4)
Tags

 Last 50 Posts
Change Theme...
  • Users » 11102
  • Posts/Pages » 29
  • Comments » 43
Change Theme...
  • VoidVoid « Default
  • LifeLife
  • EarthEarth
  • WindWind
  • WaterWater
  • FireFire
  • LightLight

Curso PHP



    No Child Pages.

About me



    No Child Pages.